Web Hosting Websites Degraded
Incident Report for
GoDaddy
Resolved
This incident has been resolved.
Posted
Sep
15
,
2026
-
11:33
UTC
Investigating
We have investigated an issue that caused websites and the control panel on the Web Hosting platform to be unavailable and latent in Asian Region.
Posted
Sep
15
,
2026
-
11:33
UTC
This incident affected: Web Hosting (Web Hosting, Web Hosting Plus).
×
Subscribe to Incident
Subscribe to updates for
Web Hosting Websites Degraded
via . You'll receive .